Combinatie VERT.ZOEKEN en INDIRECT

Stel hier je vraag over een Excel probleem
Toebak
Berichten: 2
Lid geworden op: 06 apr 2020 10:42

Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor Toebak » 07 apr 2020 07:58

Hallo,
ik heb het volgende probleem.
Ik zou de functies VERT.ZOEKEN en INDIRECT moeten combineren.
Ik heb een overzicht met tarieven van banken op een apart werkblad. Hierop zijn bereiknamen aangebracht nl ING, BNP en KBC. Er zijn 3 formules, vast, jaarlijks en vijfjaarlijks herzienbaar. Op een volgend werkblad (leningsaanbod) moet ik aan de hand van de gekozen formule en bank het juiste rente tarief weergegeven krijgen.
Dus ik zou moeten werken met zowel de VERT.ZOEKEN en de INDIRECT functie. Ik loop hier hopeloos op vast. Ik heb de file bijgevoegd...
Kan iemand mij helpen? Met de functies apart heb ik geen problemen om deze toe te passen echter de combinatie van de twee lijkt mij niet te lukken...
Alvast bedankt
Bijlagen
Tarieflijst.xlsx
(11.28 KiB) 22 keer gedownload
haije
Berichten: 76
Lid geworden op: 29 okt 2019 09:45

Re: Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor haije » 07 apr 2020 09:00

Volgens mij moet deze doen wat je verwacht:
"=VERT.ZOEKEN(B3;INDIRECT(B4);2;0)"
tknijnenburg
Berichten: 92
Lid geworden op: 18 feb 2019 17:04

Re: Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor tknijnenburg » 07 apr 2020 09:01

Dag Toebak,

Zo iets?
Bijlagen
Tarieflijst_TK.xlsx
(11.58 KiB) 28 keer gedownload
Grtz, Ton
kn-ict.com
Toebak
Berichten: 2
Lid geworden op: 06 apr 2020 10:42

Re: Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor Toebak » 07 apr 2020 10:56

haije schreef:
07 apr 2020 09:00
Volgens mij moet deze doen wat je verwacht:
"=VERT.ZOEKEN(B3;INDIRECT(B4);2;0)"
Haije,
het ziet ernaar uit dat deze formule het inderdaad doet.
Kunt u mij ook even toelichten hoe deze formule werkt? Ik probeer deze te begrijpen zodat ik ze nog kan toepassen op andere werkbladen.
alvast bedankt,
jkpieterse
Site Admin
Berichten: 644
Lid geworden op: 30 jan 2017 14:32

Re: Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor jkpieterse » 07 apr 2020 12:31

Ik denk dat Ton's oplossing beter is, INDIRECT is een functie die je beter niet kan gebruiken.
Groetjes,
Jan Karel Pieterse
jkp-ads.com
haije
Berichten: 76
Lid geworden op: 29 okt 2019 09:45

Re: Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor haije » 07 apr 2020 14:26

@jkpieterse, kun aangeven waarom INDIRECT beter niet gebruikt kan worden?

@Toebak,
B3 is de waarde die je zoekt
INDIRECT(B4) verwijst naar het bereik waarin gezocht moet worden
2 geeft aan dat je de waarde uit de tweede kolom van het bereik wilt terugkrijgen
0 geeft aan dat je naar een exact waarde zoekt in de eerste kolom van het opgegeven bereik
jkpieterse
Site Admin
Berichten: 644
Lid geworden op: 30 jan 2017 14:32

Re: Combinatie VERT.ZOEKEN en INDIRECT

Berichtdoor jkpieterse » 07 apr 2020 14:50

INDIRECT is volatile, maar vooral zijn Excel modellen waar gebruik is gemaakt van INDIRECT vaak lastig te doorgronden. Gebruik van INDIRECT is vaak een indicatie van een verkeerd basis ontwerp van het model.
Groetjes,
Jan Karel Pieterse
jkp-ads.com

Wie is er online

Gebruikers op dit forum: Bing [Bot] en 6 gasten